How to Navigate Internet Native Banner (INB)

Log in Using Internet Native Banner (INB)

a) Go to the S:\ drive. (Start button >> Computer>> S:\ drive.)
b) Open the GC_Banner_docs folder.
c) Open the file: All Banner links. htm.
d) Click on the link listed for Banner PROD.
e) Enter your Banner account and password in the login screen.
   Leave the Database field blank. You will gain access to information based on your account and security level.

Once Banner starts, you will see a main screen GUAGMNU (Fig. 1)

Fig.1. Main Screen - GUAGMNU

You can use the menus structure to access a form, job or menu. Or you can use Direct Access to go to a specific form if you know its name.

As an example, using Direct Access, enter the name of the screen SPAEMRG.

You can perform most Banner functions using either a mouse or the keyboard. The mouse functions by clicking on a button in the Menu/Toolbar.

To see the key functions, select Help> Show Keys.
Banner Forms

A form is an online document where you can enter and look up information in your database. A form visually organizes information so that it is easier to enter and read. A Banner form is similar to a paper form, except information is entered once and then used by other forms, reports, and jobs.

Parts of a Form

The following figure shows a sample form (Fig. 2). Each part of the form is described briefly in the following pages.

Menu Bar

The Banner menu bar (Fig. 3), located at the top of every form, contains pull-down menus.
You can access an option in a pull-down menu at any time, except when you are in a dialog box, alert box or List of Values (LOV). (You must respond to these windows before you can access a pull-down menu.)

**Toolbars**

The Banner toolbar (Fig. 4) contains buttons that perform common functions. It is located directly under the menu bar:

![Fig.4. Banner toolbar](image)

**Title Bar**

The title bar (Fig. 5) shows the following information:

- Descriptive form name
- Form name (seven or eight characters)
- Release number
- Database name from the Installation Control Form (GUAINST)

![Fig.5. Banner Title bar](image)

**Blocks**

A block is a section of a form or window that contains related information. If a form or window contains more than one block, each block (except the key block) may be enclosed in a beveled box.

**Key Block**

The first block on most forms contains key information. (Some forms, especially validation forms and certain list forms do not have a key block.) The key block determines what is entered or displayed on the rest of the form. All information on the form refers to the key block. When the cursor is in the key block, enterable fields in the key block are enabled. When you leave the key block, enterable fields in the key block are disabled.
Other Blocks
Other blocks contain additional details for the key information. Each block contains related information and is usually enclosed in a beveled box.

Auto Hint
The auto hint at the bottom of the form (Fig. 6.) can contain the following information for the field where the cursor is located:

- Brief field description
- Error and processing messages
- Keyboard equivalents, if you can access other blocks, windows, or forms from the field.

![Image of Auto Hint](image)

Status Line
The status line directly under the auto hint can contain one or more of the following messages:

Record n/n
Shows the number of the current record followed by the total number of records in the current block. If there are more records than fit in the window, the total appears as a question mark (for example, 3/?) until you scroll to the last record in the block. Once the last record is displayed, the total appears as a number (for example, 3/15).

List of Values
Indicates the field has a List of Values.

Naming Banner Objects
Banner form, report, job and table names have a 7-character structure. The first and second characters identify the system and module, the third character identifies the type of object, and the four remaining characters are used as a unique identifier for the object. For example, see Fig. 7:

![Image of Banner Object Names](image)
Getting Around Banner

Banner provides numerous ways to navigate through the system:

Main menu
You can select from a list of the menus, forms, jobs and QuickFlows in Banner.

Direct Access
You can access a menu, form, job or QuickFlow by its name.

Objects Search
You can access a form, job, or QuickFlow if you know part of its name, description or type.

Site map
You can view a list of the top-level menus and one level below them.

Tabs
You can access windows on tabbed forms by selecting the tab.

Options menu
You can access other forms, windows, and blocks related to the current form, window, and block.

Option list
You can right-click on a form anywhere outside a field to display the Option list from which you can perform functions, navigate to other parts of the form, or add the form to your personal menu.

Buttons
You can access another form or window related to the current record or field.

Mouse
You can click on iconic button, field, record, block, or window that is currently displayed.

Keyboard
You can use keyboard to access a form, window, block, or field.

QuickFlow
You can automatically access forms that are linked in a chain.

Last 10 forms
Last 10 forms in the File pull-down menus.

You can quickly re-access a form that was previously opened in the current session.
Banner Querying

Querying is the process of looking to see what information is already entered in the Banner database. You can inquiry forms, query forms, and most application forms to perform queries.

Some forms automatically open in query mode, usually because a large number of records would have to be retrieved. When a form opens in a query mode, **Enter Query** appears in the status line. you can immediately specify search criteria to narrow the search. If a form does not open in query mode, you must put the form into query mode before you can enter search criteria.

**Query Functions**

Use the following functions to perform queries:

- **Enter** - Puts the form into query mode so you can enter search criteria to see what information is already in the database. **Enter Query** appears in the status line.

- **Execute** - Searches the database and displays the first set of records that match your search/criteria. This function is enabled only if you are in query mode.

- **Last Criteria** - Enters the criteria from your last search. You can change any of the criteria. This function is enabled only if you are in query mode.

- **Exit or Cancel** - Cancels the query and takes the form out of query mode. (Note: If you aren't in query mode, the Cancel Query button on the toolbar exits you from the form.)

- **Count Query Hits** - Counts the number of records that match the search criteria and displays that number in the auto hint.

- **Fetch Next Set** - Replaces the current set of displayed records with the next set of records if more records match the search criteria than fit in the window. This function is enabled only if you are in query mode.

**Features of Banner**

**Extract**

You can extract data from a Banner form to a spreadsheet. You can extract detail data from the current block with or without data from the key block. Once Banner data is in a spreadsheet, you can easily graph and report the data.

To extract data in Banner:

1. Access the Banner form.
2. If applicable, display the desired record on the form.
3. Select one of the following options from the Help pull-down menu:
   - Extract Data with Key (to extract key data and data in the current block)
   - Extract Data No Key (to extract data in the current block only)
   - Extracted data is displayed in a browser window
4. For Internet Explorer, use the browser **File >> Save As** option to save the extracted data to a local directory as a .txt file, then rename the file as a .csv file.

   OR

   For Netscape, use the browser **File >> Save As** option to save the extracted data to a local directory as a .csv file.

**Calendar**

There are three ways to display the calendar:

- Double-click any data field, or click the **Calendar** button. If the date field has a value, the calendar highlights that date. If the date field is empty, the calendar highlights the current date. You can double-click a date on the calendar to return it to the calling form.

- Use Direct Access to display the **Calendar Form** (GUACALN). When accessed this way, the calendar works independently of any form or field. You cannot select a date and return it to a form.

- Select **Help > Calendar**. When accessed this way, the calendar works independently of any form or field. You cannot select a date and return it to a form.

**Calculator**

Double-click any numeric field, or click the Calculator button. If the numeric field has a value, the calculator shows that value. You can use the mouse, number keys on the keyboard, or the numeric keypad (if the NumLock is enabled) to make calculations. When you're done, click the OK button to return the calculated value to the calling form.

**Using Help**

Banner has several kinds of help that can give you immediate online assistance:

- **Online help.** This is online information about forms and fields as well as tasks you can perform with Banner. Click the Online Help button in the toolbar.

- **Dynamic Help.** This is the original help for Banner forms, blocks, and fields, Banner Dynamic Help is gradually being replaced by online help.

**Dynamic Help**

Dynamic Help is the traditional help for Banner forms, blocks, and fields. Once again, Dynamic Help is gradually being replaced by online help.

Banner provides two kinds of Dynamic Help:

- **Banner Dynamic Help.** This help is delivered with system upgrades. You can change this help text, but each system upgrade overwrites your changes. Dynamic Help is gradually being replaced by online help.

- **Local Dynamic Help.** This help is completely written and maintained by your institution. System upgrades do not affect this help text. This is the default when you access Dynamic Help. Maintain your institution’s custom information with local Dynamic Help.
1. Select **Help > Dynamic Help Query**. The **Help Form** (GUAHELP) appears. The default selection criteria indicate Local Dynamic Help for the current field.

2. Verify the default selection criteria. Change if necessary.

3. Select the Next Block function. The Help Text window shows help text for requested item.

### Customizing the Look and Feel of Banner

You can customize the Banner to meet your individual needs. For example, you can:

- Create a personalized menu with My Banner
- Choose what information appears in title bars
- Specify whether form names are displayed on menus
- Customize the appearance of the main menu

#### My Banner

My Banner includes the forms, jobs, menus, and QuickFlows that are most important in your daily work. You can access My Banner from the main menu; it is tied to your Oracle user ID.

The following forms are used to create and copy My Banner menus:

- The **My Banner Maintenance Form** (GUAPMNU) lets you create and change My Banner.

#### Title Bar Display Options

You can choose to display any or all of the following in title bars:

- Form names
- Release numbers
- Database instances

#### Changing Your Banner Colors

You can customize your colors for Banner via the **General User Preferences Maintenance Form** (GUAUPRF). Custom colors can be specified at the individual user level, by changing the values in the User Value fields.

You can customize the color of the following items:

- Buttons, such as Cancel and OK (buttons in the toolbar are not included).
- Canvas of all forms
- Record highlighting
- Scroll and separator bars
- Canvas within the main menu, including the broadcast message, menu, and menu tree canvases

#### Changing Your Banner Password

The **Change Banner Password** link goes to the **Oracle Password Change Form** (GUAPSWD), where you can change your password.
Other Navigation Tips/ Tricks

- The Rollback function clears out the record and takes you back to the key block, so you can take another snapshot from the database or enter another ID number.
- Double-clicking in a number or date field will display the calculator or calendar, respectively.
- You must always perform an Enter Query function before performing and Execute Query function. Even if the form is blank when you access it, you must ensure it is in Enter Query mode.
- If you have not selected a record after your query, and wish to execute another, you can perform two Enter Query functions in a row, and Banner will retrieve the last set of query criteria you executed.
- The character __ represents a single character in your query, while the character % represents any number of continuous characters.

ID Affiliation (GUASYST)
Sometimes it is useful if there is a way to determine an ID's affiliation, whether a person is a student, an employee etc. For this purpose you can use the screen GUASYST. Again in Direct Access, you will type in the name of the form GUASYST. Type in the ID or search for an individual in SOAIDEN, bring the ID to GUASYST and you can see an ID's identities in a banner.

How to Exit Banner
X on the Toolbar closes the current screen and eventually exits you out of Banner. Exit from Banner using File > Exit Banner on the Menu bar.

How to Seek Help
Please review the sections above titled Using Help and Dynamic Help that discusses available help options.

In Banner’s main screen, there is a My Link section. This section has Banner Service Request Form. Click that, fill the form and submit. Make sure Pop-up blocker is OFF.

Sungard Support Website
The link to Sungard (ellucian) Customer Support website is:

https://connect.sungardhe.com/customer_support

Banner Documentation
Banner documentation URL

s://gc_banner_docs (s://gc_banner_docs)